For all users with Android or Apple devices, the critical update of the Neo Smart Blinds app, version 5.3.0, is now available on both the Google Play Store and the Apple App Store. This update restores full functionality to the Add Blind, News, and Technical Support pages.
If you can’t update right away and are using version 5.2 or earlier, you can still control rooms, blinds, and scenes, and create new schedules and scenes. The Smart Controller remains fully operational and continues to run schedules as expected. To add blinds or view News and Technical Support information, please use the web app at app.neosmartblinds.com.
Thank you for your patience!
Posted Apr 10, 2025 - 16:45 EDT
Monitoring
We’re pleased to announce that Neo Smart Blinds app version 5.3.0 is now available on the Google Play Store for Android devices. This critical update restores the Add Blind functionality, as well as access to the News and Technical Support pages within the app. We recommend all Android users update to the latest version to ensure full functionality.
The update has also been submitted to the Apple App Store and is currently under review. We will provide an update as soon as it becomes available for iOS. For iOS beta testers, version 5.3.0 is already available.
Thank you for your continued patience.
Posted Apr 10, 2025 - 14:01 EDT
Update
We have implemented a partial fix to solve the issue, and the service has been partially restored. Users can now access their accounts, control rooms and blinds, and play scenes. Additionally, the Smart Controller is now able to run room schedules. However, some features remain temporarily unavailable. At this time, it is not possible to add blinds via the mobile app, and the News and Tech Support sections are also inaccessible.
To add blinds, please use the web app at app.neosmartblinds.com.
Final Resolution: We are finalizing a new app version, which will be submitted to the App Store and Google Play shortly. Please note that approval and availability may take 1–2 days, depending on each platform’s review process.
We appreciate your continued patience and understanding as we work to fully restore all functionality.
Posted Apr 10, 2025 - 13:06 EDT
Identified
We have pinpointed the underlying issue and our team is actively working to reestablish full functionality of the Neo Smart Blinds app and Smart Controller.
In the meantime, some users may remain logged into their accounts but experience missing account information such as rooms, paired blinds, and scenes. Please rest assured that no data has been lost—the account information is temporarily unavailable due to the service disruption.
We appreciate your continued patience as we work toward a resolution.
Posted Apr 10, 2025 - 12:13 EDT
Investigating
We have identified that the Neo Smart Blinds app is currently unavailable worldwide and are actively investigating the issue. Our team is working diligently to restore full functionality as quickly as possible. We appreciate your understanding and patience during this time.
Posted Apr 10, 2025 - 11:42 EDT
This incident affected: Neo Smart Blinds App (Android app, Android app - beta version, iOS app, iOS app - beta version, Web App, Smart Controller - model WC100, Smart Controller - model C-R200, Smart Controller - model C-BR300).